macbookpro m1 安装php56

/ 0评 / 2

木办法,很老的项目只能用php56

m1中有arm版本的brew和老版本的brew,这里brew指的老版本的
我两个版本都安装了,具体安装方法网上很多教程
我这里找了一个
安装 Homebrew (ARM/M1)

sudo mkdir /opt/homebrew
sudo chown $(whoami) /opt/homebrew
curl -L https://github.com/Homebrew/brew/tarball/master | tar xz --strip 1 -C /opt/homebrew

安装 Homebrew(Intel)

arch -x86_64 /bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"

为例避免两个 brew 相冲突,我的做法是:

alias xbrew="arch -x86_64 /usr/local/bin/brew"
alias abrew="/opt/homebrew/bin/brew"

下面两步只是安装了php56,但是运行时还是会报错

brew tap exolnet/homebrew-deprecated
brew install php@5.6

下面是替换openssl,因为之前版本的brew switch已经不支持了,只能用link命令了

wget https://github.com/tebelorg/Tump/releases/download/v1.0.0/openssl.rb
brew install openssl.rb
brew link openssl
echo 'export PATH="/usr/local/opt/openssl/bin:$PATH"' >> ~/.zshrc

准备好一份老的64.2,放到/usr/local/Cellar/icu4c/中
需要老版本的64.2请留下邮箱
因为不能用brew switch命令,所以这里直接ln去指向

cd /usr/local/opt/
rm -rf icu4c
ln -s /usr/local/Cellar/icu4c/64.2  icu4c

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注